Portfolio page issue on Internet Explorer

#244 Portfolio page issue on Internet Explorer

  • Author
    Posts
  • #244

    skgali
    Participant

    I tried to load Portfolio page on internet explorer, but the contents are not loaded. Please help me with this issue.

    #245

    IKON Support
    Keymaster

    We support Edge 12 and newer (they are auto-updated though so version 12 is no longer available for download/use).
    The website should work also in Internet Explorer 10 and 11 but we do not actively test it there.

    We support all browsers with high usage share.

    https://en.wikipedia.org/wiki/Usage_share_of_web_browsers

    Please provide your Internet Explorer version.

    #246

    skgali
    Participant

    Our clients tried on Internet Explorer 9, 10 and 11 and the portfolio page contents does not load. It works fine on Edge browsers. I think there is some issue with Portfolio page jQuery on Internet Explorer.

    #247

    IKON Support
    Keymaster

    We checked this in Internet Explorer 11 today and that browser seems to not be supporting several necessary features. See: https://kangax.github.io/compat-table/es6/

    Usage of backticks in front.js is causing the error but there may be more errors.

    It would not be beneficial to downgrade our code that much to support that.

    It might not be even possible to change our code to support IE11 because the libraries that we bundle or WordPress core libraries may be using (now or in the near future) one of the non-supported functions.

    Furthermore, Internet Explorer is officially not recommended by Microsoft (they write it’s left only for backwards compatibility) and may stop receiving updates in the near future: https://support.microsoft.com/en-ph/help/17454/lifecycle-faq-internet-explorer

  • You must be logged in to reply to this topic.