Can’t update from version 2 to 3

#198 Can’t update from version 2 to 3

Tagged: 

  • Author
    Posts
  • #198

    donorbrain
    Participant

    Hi there! I’ve been using your themes since 2013 and i need to update to Daisho version 3. I tried replacing the Functions.php with the code on github but this doesn’t seem to make a difference. What am i doing wrong? Is there a tutorial somewhere on what exactly i’m suppposed to do to upgrade from version 2 to 3?

     

    Thanks for your help!

    #199

    IKON Support
    Keymaster

    Hi there,

    Please don’t update your v2.x to v3.x because v4.x is coming very soon. It will be available for download on https://docs.ikonize.com/daisho/repository.php probably this or next week.

    Updating from v2.x to v3.x works normally:

    1. Rename your old folder to “daisho-backup”.
    2. Upload the theme again to “daisho” folder.
    3. Enter every page and check what doesn’t work (because you’re updating between major and distant releases and it’s certain that some things changed) and fix whatever may not work (if anything). These will be usually minor changes (like renamed shortcode or a custom field). Most or all changes are going to be fixed automatically.

    The Github code snippet can be considered to be deprecated because it was converting old custom field names (like flow_post_description) to new custom field names (like daisho_description). But in v4.x this custom field will be gone altogether and it will be replaced with a “page description” Gutenberg block.

    We recommend that you install Gutenberg (https://wordpress.org/plugins/gutenberg/) and wait for a Daisho update. (Please don’t worry about its low rating, the plugin is very good technically (better than any other page builder for WordPress to date) but the low ratings are arriving while it’s in development and still unusable).

    #203

    donorbrain
    Participant

    Hey there!

    Thanks again for the feedback, i’ve updated to Daisho v4x.

    However there are some minor things i’m trying to alter. One of them being that the way the portfolio thumbnails are aligned. I would like them to be equal sizes as default when the page loads. Instead of being all different sizes. So for me there is no need for a ‘toggle’ option to change the layout of the portfolio items. I’ve tried to change this by editing the file ‘front.js’ in the folderĀ /plugins/daisho-blocks/blocks/isotope however i can’t get it to work. Can you give me some directions what i need to change or comment out in order to have just one layout for the portfolio items (even sizes) instead of having two?

    Thanks for help again!

    • Jacco
    #204

    IKON Support
    Keymaster
    • You can set the “small” size for each project in Portfolio > (each project).
    • Perhaps the easiest would be pasting .ns-filter-size { display: none; } to Appearance > Customize > Additional CSS. The CSS class naming is likely to change in the future.
    #205

    donorbrain
    Participant

    Thanks again for the help! I’ve adjusted the layout successfully.

    Another question: I made an API key for the google maps function on the contact page. However i get an error (the “oops something went wrong”).

    Is this because i need to set restrictions in the google cloud platform with the API key?

    And what kind of API key do i need to generate? One for ‘Maps Static API’ ?

    I’m not really familiar with this environment (google cloud platform)

    #206

    IKON Support
    Keymaster

    You can find more information about ikon/google-map block on https://docs.ikonize.com/daisho/

    What you need to enable depends on whether you’ll be setting longitude and latitude manually or by specifying an address. In addition styled (grayscale) map requires “Maps JavaScript API” while not styled map could probably get away without using the “Maps JavaScript API” (however, in the case of this block “Maps JavaScript API” is always required at this moment even if technically it would be possible to not use it). The demo website generates such requests for us:

    1. Directions API – 0
    2. Geocoding API – 2
    3. Geolocation API – 0
    4. Maps Embed API – 119
    5. Maps JavaScript API – 148
    6. Places API for Web – 0

    If you enable all of these your map should be working.

    “Oops something went wrong” error is unexpected. The API should be informing you why the map is not being displayed.

    Our ikon/google-map block is in early stages of development and we’re planning to improve it further and we’ll probably catch and fix some issues about it but if you want us to investigate the “Oops something went wrong” error faster (now) we’d need more details on how to reproduce this error.

    #210

    donorbrain
    Participant

    Hey there!

    I managed to make the API key and attach the required API’s to them. However i still get an Javascript error in the console and i’m not sure where(which plugin or daisho) this is coming from:

    Uncaught TypeError: Cannot read property ‘uid’ of undefined
    at (index):73
    at (index):83

    <script type=’text/javascript’>
    ( function() {
    var userId = window.userSettings.uid;
    var oldStorageKey = “WP_EDIT_POST_DATA_” + userId;
    var storageKey = “WP_DATA_USER_” + userId;
    if ( localStorage[ oldStorageKey ] ) {
    localStorage[ storageKey ] = localStorage[ oldStorageKey ];
    delete localStorage[ oldStorageKey ];
    }
    wp.data
    .use( wp.data.plugins.persistence, { storageKey: storageKey } )
    .use( wp.data.plugins.controls );
    } )()
    </script>

     

    Could you please help fix this? i get the same error on two websites using Daisho:

    http://www.jeroenstijlaart.com/contact/

    http://www.nielslelieveld.com/contact/

    #211

    IKON Support
    Keymaster

    The above is not a theme error.

    Currently the maps block works for us. Does it work for you?

    Gutenberg 3.6.2 doesn’t cause any errors for us.

  • You must be logged in to reply to this topic.